Opened 6 years ago

Closed 6 years ago

#4724 closed defect (duplicate)

Error in Nominatim search

Reported by: meghaltam@… Owned by: geocoding@…
Priority: major Milestone:
Component: nominatim Version:
Keywords: Cc:

Description

When I try to find information about a street, using it's name, I discovered a strange thing.

If I search for the street "Strada Anton Pan" stored with ID number: 42042650 in the following way, I get an empty array: " http://nominatim.openstreetmap.org/search?format=json&q=Anton%20Pan,Satu%20Mare,Satu%20Mare,Romania ".

But if I only give one word from the streets name, like: " http://nominatim.openstreetmap.org/search?format=json&q=Anton,Satu%20Mare,Satu%20Mare,Romania " I get the correct data.
The name field of this id is as follows: "Strada Anton Pan, Satu Mare, Municipiul Satu-Mare, Satu Mare, 440182, Romania"

This thing is true to all street names, where the name contains a space in it, for example George Cosbuc, Ilarie Chendi(all of them from Satu Mare, Satu Mare, Romania). By searching for the whole name, I get an empty array, but if I search for only one word, I get the desired result.

I don't know if this is a bug, or is intended this way, but please take a look.

Change History (1)

comment:1 Changed 6 years ago by lonvia

  • Resolution set to duplicate
  • Status changed from new to closed

multi-word substrings are currently not supported

duplicate of #3733

Note: See TracTickets for help on using tickets.