Opened 8 years ago

Closed 10 months ago

#4740 closed defect (fixed)

trace import fails when editing tag while "waiting"

Reported by: malenki Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: Cc:

Description

Yesterday I uploaded some GPX data. At one file I enhanced the description while it's status was "Waiting" on the trace list After refreshing the list the file was gone and I received this email:

It looks like your GPX file
  2012_12_garmin_bearb.gpx.gz
with the description
  Logs Dezember 2012
and the following tags:
  2012
  sachsen
failed to import. Here's the error:
  Issue while inserting job into database

I uploaded the file again (without any altering) with the correct description from the start and voila:

It looks like your GPX file
  2012_12_garmin_bearb.gpx.gz
with the description
  Logs Garmin Dezember 2012
and the following tags:
  2012
  sachsen
loaded successfully with 61227 out of a possible 61227 points.

Change History (2)

comment:1 Changed 8 years ago by malenki

Summary: traceimport fails when editing tag while "waiting"trace import fails when editing tag while "waiting"

comment:2 Changed 10 months ago by Andy Allan

Resolution: fixed
Status: newclosed

We've substantially changed the trace import processing since this ticket was originally created, and I suspect that it will no longer be an issue.

However, if it can be reproduced, please open a new issue at https://github.com/openstreetmap/openstreetmap-website and we can investigate.

Note: See TracTickets for help on using tickets.