Opened 6 years ago

Closed 6 years ago

#4758 closed defect (fixed)

libapache2-mod-tile cannot download 10m-populated-places.zip and 110m-admin-0-boundary-lines.zip causing install crash

Reported by: jtback Owned by: jburgess777@…
Priority: minor Milestone:
Component: mod_tile Version:
Keywords: Cc:

Description

OS: Ubuntu 12.10

Following directions from: http://switch2osm.org/serving-tiles/building-a-tile-server-from-packages/

libapache2-mod-tile produces a ERROR 404 when trying to download from: http://www.naturalearthdata.com/http//www.naturalearthdata.com/download/10m/cultural/10m-populated-places.zip

and

http://www.naturalearthdata.com/http//www.naturalearthdata.com/download/110m/cultural/110m-admin-0-boundary-lines.zip

the files are not longer available on the server causing the install to crash later on.

Change History (4)

comment:1 Changed 6 years ago by Tom Hughes

Priority: criticalminor
Resolution: fixed
Status: newclosed

I'm not clear exactly what step of the instructions on switch2osm does the download of these files, but I don't think it's actually anything to do with mod_tile itself is it? In which case this is the wrong place to report it.

If it's just the instructions on switch2osm that need updating then you should contact the authors of that site, and if it's an auxiliary script that is part of the Ubuntu mod_tile package then you should talk to Kai who creates those packages.

In any case the files have just moved slightly. The first one is at:

http://www.naturalearthdata.com/http//www.naturalearthdata.com/download/10m/cultural/ne_10m_populated_places.zip

and I think the second one is:

http://www.naturalearthdata.com/http//www.naturalearthdata.com/download/110m/cultural/ne_110m_admin_0_boundary_lines_land.zip

comment:2 Changed 6 years ago by Tom Hughes

Resolution: fixed
Status: closedreopened

comment:3 Changed 6 years ago by amm

The issue comes from the script get-coastlines.sh which is part of the mapnik stylesheets. The correct URL has been fixed in the svn repository a while ago ( https://github.com/openstreetmap/mapnik-stylesheets/commit/ca84439e6aed159d88cb487a5d28bae570cc4e41 )

The problem you are facing is that the Ubuntu packages linked to in the swtich2osm.org haven't been repackaged in a while, so don't include the fix yet.

It is also not directly part of the mod_tile package, but the stylesheet package which gets pulled in by mod_tile as a recommended package.

comment:4 Changed 6 years ago by amm

Resolution: fixed
Status: reopenedclosed

This should be fixed now in the new packages.

Note: See TracTickets for help on using tickets.