Opened 12 years ago

Closed 11 years ago

#484 closed enhancement (fixed)

Add maplint as an overlay layer

Reported by: Deelkar Owned by: Tom Hughes
Priority: minor Milestone:
Component: website Version:
Keywords: Cc: Knut Arne Bjørndal

Description

Maplint is now rendered as transparent pngs (single color transparency, not alpha, should work in IE, too) so it would make sense to enable maplint as an overlay for the slippy map.

Change History (6)

comment:1 Changed 12 years ago by Knut Arne Bjørndal

Cc: Knut Arne Bjørndal added

The following code sets up the overlay in openlayers:

  layerMaplint = new OpenLayers.Layer.TMS(
  "tiles@home (Maplint annotation)",
  "http://dev.openstreetmap.org/~ojw/Tiles/maplint.php/",
  {type:'png', getURL: get_osm_url, isBaseLayer: false} );
  layerMaplint.setVisibility(false);
  map.addLayer(layerMaplint);

comment:2 Changed 12 years ago by 80n80n@…

Resolution: fixed
Status: newclosed

Done for www.informationfreeway.org

comment:3 Changed 12 years ago by Knut Arne Bjørndal

Component: slippy_maprails_port
Resolution: fixed
Status: closedreopened

Patch suitable for the main openstreetmap.org site:

--- app/views/site/index.rhtml  (revision 3055)
+++ app/views/site/index.rhtml  (working copy)
@@ -82,6 +82,9 @@
     map.addLayer(layer);
     layer = new OpenLayers.Layer.LikeGoogle( "Osmarender", "http://dev.openstreetmap.org/~ojw/Tiles/tile.php/", {type:'png'} );
     map.addLayer(layer);
+    layer = new OpenLayers.Layer.TMS( "Maplint", "http://dev.openstreetmap.org/~ojw/Tiles/maplint.php/", {type:'png', getURL: get_osm_url, isBaseLayer: false} );
+    layer.setVisibility(false); // Maplint should not be visible by default
+    map.addLayer(layer);
 
     //Marker stuff

comment:4 Changed 12 years ago by Tom Hughes

Component: rails_portwebsite
Owner: changed from steve@… to Deelkar
Status: reopenednew

The problem is the maplint layer (or at least large parts of it) do not actually appear to be transparent... Pass the ticket back to me when that is sorted and I can fix the slippy map to include it.

comment:5 in reply to:  4 Changed 11 years ago by Knut Arne Bjørndal

Owner: changed from Deelkar to Tom Hughes

Replying to tom@compton.nu:

The problem is the maplint layer (or at least large parts of it) do not actually appear to be transparent... Pass the ticket back to me when that is sorted and I can fix the slippy map to include it.

As said in #612 this looks good now.

comment:6 Changed 11 years ago by tomhughes

Resolution: fixed
Status: newclosed

(In [6196]) Add a maplint layer to the map. Note that the t@h server currently serves solid grey tiles for tiles which are not in the database which limits the utility of this.

Closes #484.

Note: See TracTickets for help on using tickets.