Opened 6 years ago

Closed 6 years ago

#4867 closed defect (duplicate)

Searching with a postcode returns no results.

Reported by: stevie_ Owned by: geocoding@…
Priority: major Milestone:
Component: nominatim Version:
Keywords: postcode Cc:

Description

For example, querying the following Northern Irish address returns a single accurate result: "220 Ravenhill Avenue, Belfast".

However, if I append the correct postcode to the query (either the full postcode or the first segment), no results are returned: "220 Ravenhill Avenue, Belfast, BT6 8LL" or "220 Ravenhill Avenue, Belfast, BT6"

I have encountered similar behaviour for a number of NI addresses but have noted that this isn't always the case when searching, for example, addresses in London.

After further digging, this appears to be due to there being no postal code information for NI.

I believe the current behaviour to be incorrect. If the post code isn't one which is known, at very least, it should be omitted and results should be returned for the query sans post code.

Change History (1)

comment:1 Changed 6 years ago by Sarah Hoffmann

Resolution: duplicate
Status: newclosed

The postcode you are looking for does not exist in the OSM database and we do not have external resources for Northern Ireland. As you noted, Nominatim cannot resolve a query with a post code when it does not know about the post code. That is an issue and, as it happens, it is also very well known.

Please look through existing bug reports before reporting an issue. And especially, before reporting an issue three times.

Closed as a duplicate of #2497, #2638 and a few others.

Note: See TracTickets for help on using tickets.