Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#4892 closed defect (fixed)

Registration on osm.org fails with HTTP 500 if cookies are not accepted in the user's browser

Reported by: aseerel4c26 Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: cookies http500 Cc:

Description

in the standard user registration process (with email, username and password) https://www.openstreetmap.org/user/new after accepting the contributor's terms https://www.openstreetmap.org/user/terms the next page is https://www.openstreetmap.org/user/save displays which displays a HTTP 500 error without further details. Tested with Opera 12, cookies not accepted, no old cookies were existent, "rest of world" was preselected, "public domain" checked. Confirmed by another user who stumbled over this problem first.

Expected: if cookies are really required then there should be some user friendly message telling about this.

Change History (6)

comment:1 Changed 6 years ago by Tom Hughes

Historically I don't think cookies were required during signup which is probably why we don't show an alert, but the introduction of the terms screen means that they are now required to track progress through the signup process.

comment:2 Changed 6 years ago by Tom Hughes

Fixed in e5e6db8/rails.

comment:3 Changed 6 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

comment:4 Changed 6 years ago by aseerel4c26

Fine, thank you! The old cookie warning on the /login page works, but not (yet) on /user/new. I assume that is just because the change takes some time to be live.

comment:5 Changed 6 years ago by Tom Hughes

I only just pushed it to live, because I had to fix the tests first - it should be live in the next half hour.

comment:6 Changed 6 years ago by aseerel4c26

works, thank you. Now the user just need to see the red banner. ;-)

Note: See TracTickets for help on using tickets.