Opened 12 years ago

Closed 12 years ago

#492 closed defect (fixed)

Downloading some areas gives 500 error

Reported by: hakon.enger@… Owned by: steve@…
Priority: major Milestone:
Component: api Version:
Keywords: Cc:

Description

I get a 500 error from the API with the error message "Change this error message for exceptions thrown outside of an action (like in Dispatcher setups or broken Ruby code) in public/500.html" whenever I download an area containing either the node with id 160 or 166 (and/or possibly other nearby nodes). E.g., http://www.openstreetmap.org/api/0.4/map?bbox=10.772544982982192,59.94839283486548,10.805747042370106,59.962748718624916

which should contain both these nodes as well as several other nodes, segments and ways. Downloading nearby regions works as expected.

Change History (4)

comment:1 Changed 12 years ago by Tom Hughes

I can't reproduce this in my test environment with last week's planet.

Interestingly last weeks planet has nodes 160 and 166, but the live database no longer seems to contain node 166 so that is probably the problem as segments 158 and 159 still exist and they both reference node 166 that no longer seems to exist.

comment:2 Changed 12 years ago by hakon.enger@…

Tom, can you take another look at this when a new planet file arrives (hopefully today)? You mention node 166, but I also have problems with node 160, e.g.,

http://www.openstreetmap.org/api/0.4/map?bbox=10.769970198956372,59.95092828480737,10.78089018170452,59.955650184631516

Node 160 still exists in the database, but any bbox which includes that node still returns a 500 error. If you think there is anything I or any other user (ie, not developer) can do to solve these problems, please tell me about it. The errors are irritating, and I think tiles@home rendering fails for northern Oslo because of them.

comment:3 Changed 12 years ago by hakon.enger@…

I deleted segments 152, 159, and 1387 (which referenced nodes 116, 160 and 167, which seemed to give 500 errors) and now I think the 500 errors are gone for Oslo, at least. I still think there are some data inconsistencies, such as ways refering to deleted segments or segments refering to deleted nodes, though.

comment:4 Changed 12 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

Hopefully all the inconsistencies have been fixed now - certainly both these URLs now work.

Note: See TracTickets for help on using tickets.