Opened 6 years ago

Closed 5 years ago

#4921 closed enhancement (duplicate)

[landcover] Rendering of natural=valley tags with bigger font size

Reported by: ircama Owned by: mapnik-team@…
Priority: major Milestone: Wishlist
Component: mapnik Version:
Keywords: Cc:

Description

Two considerations on lines including natural=valley tag:

  • natural=valley has very limited usage (Openstreetmap currently lacks of information related to valley names)
  • when using natural=valley in a line, the adopted font is very small (the same as streets); besides, the zoom visibility is limited to the highest ones.

In order to provide a decent mapnik rendering for valleys and incentivate the usage of natural=valley, I suggest to adopt an automatically resizable font for the name tag with automatic character spacing; zoom visibility shall also be extended to additional levels.

This change could be implemented in two steps: the former could consist in a static font size (bigger than the one now used), a fixed (larger) character spacing and more allowed zoom levels, while the latter could introduce dinamic font size and dinamic character spacing according to the line length.

Attachments (3)

map sample1.png (230.0 KB) - added by ircama 6 years ago.
map.png (200.2 KB) - added by ircama 6 years ago.
another sample
map1.png (220.5 KB) - added by ircama 6 years ago.
additinal sample

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by clockwerx

Are you able to attach screenshots or link to an area that shows the issue?

Changed 6 years ago by ircama

Attachment: map sample1.png added

Changed 6 years ago by ircama

Attachment: map.png added

another sample

Changed 6 years ago by ircama

Attachment: map1.png added

additinal sample

comment:2 Changed 6 years ago by ircama

This example shows an Openstreetmap rendering which is almost useless for topographical purposes:

http://www.openstreetmap.org/?lat=45.8957&lon=10.0074&zoom=14&layers=M

No description of places, ridges and valleys. If you need something to study a mountain region, you currently need to leave out Openstreetmap and select other cartographic systems.

The dramatic problem is related to the virtual extension of this issue, which might cover all European Alpine area (and possibly a relevant part of the world territory).

The most important aspect is related to missing information in Openstreetmap database, but this is not even the case of the above mentioned URL: as a matter of fact, if you go to this zoom

http://www.openstreetmap.org/?lat=45.89188&lon=10.00812&zoom=15&layers=M

you can read terms as “Moia”, “Costa pü Stomegard”, “Valle Righenzolo”, “Valle di Bì”, “Zenecla”, “Arec”, etc.

This is because this region includes tags like natural=ridge and natural=valley.

Even if the linear geometric orientation of these terms is correct, you might notice that not only they are not shown at low zoom levels, but also that their font and character spacing does not allow to clearly render the name of these places. Each name should have been distributed along the whole length of the related line with wider font size.

In my opinion this is currently the major Openstreetmap and Mapnik drawback.

Check the attached sample “map sample1.png”, which is a printscreen of JOSM for this region, where Openstreetmap data are layered over a topographical map correctly representing places, ridges and valleys. To highlight the region names, I enclosed them with blue drawings. You might notice valid fonts and character spacing close to the related JOSM lines that are wrongly rendered by Mapnik.

Notice also that, even if this ticket relates to natural=valley, the issue is the same for natural=ridge. http://wiki.openstreetmap.org/wiki/Proposed_features/ridge

I have attached some samples of other topographical maps representing this kind of names (see map.png and map1.png).

comment:3 Changed 5 years ago by math1985

Summary: Rendering of natural=valley tags with bigger font size[landcover] Rendering of natural=valley tags with bigger font size

comment:4 Changed 5 years ago by math1985

Resolution: duplicate
Status: newclosed

This issue is now being discussed on Github: https://github.com/gravitystorm/openstreetmap-carto/issues/787

Therefore, I will close the issue here.

Note: See TracTickets for help on using tickets.