Opened 5 years ago

Last modified 5 years ago

#4942 reopened defect

Constantly updated permalink in URL bar (hash style) spams browsing history in Firefox

Reported by: aseerel4c26 Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: Cc:

Description

Constantly updated permalink in URL bar (hash style) spams browsing history in Firefox. I don't like that. E.g. navigating back using the back button is impossible after you did a few drags and zooms. There IS already the "share" menu (by the way: why do I need to use "share" if I just want to do a bookmark for myself …?)

Change History (7)

comment:1 Changed 5 years ago by TomH

  • Resolution set to wontfix
  • Status changed from new to closed

It only spams the global history - it does not affect the local history as used by the back/forward buttons.

The spamming of the global history was considered at length during the development of this feature and was decided not to be a significant problem.

comment:2 Changed 5 years ago by aseerel4c26

I was nearly sure that I had seen the many entries also in the back button drop down. However, I cannot reproduce that now.

Re. spam in the browser history: not nice, though. What about making that spamming optional? I like to navigate back several page - the "History" menu of Firefox offers that with two clicks... now not anymore. Furthermore the history of a day of browsing osm.org maps gets full... really spammy. Other pages are pushed away in the history.

What about a checkbox in the share menu ("enable auto-permalink")? This could get filled by a user setting (for logged-in users).

Last edited 5 years ago by aseerel4c26 (previous) (diff)

comment:3 Changed 5 years ago by lonvia

Try this Greasemonkey script if you don't like the history spamming: http://userscripts.org/scripts/show/175199

comment:4 Changed 5 years ago by aseerel4c26

Thanks lonvia! I have use misused NoScript's surrogate scripts for that. Works.

noscript.surrogate.osmorg.sources;@www.openstreetmap.org
noscript.surrogate.osmorg.replacement;document.addEventListener('DOMContentLoaded', function() { L.Hash.prototype.onMapMove = function() {}; }, false);

Last edited 5 years ago by aseerel4c26 (previous) (diff)

comment:5 Changed 5 years ago by aseerel4c26

That patch does not work for edit mode (Potlatch2). Does someone have a snippet for this?

comment:6 Changed 5 years ago by aseerel4c26

The workaround does not work anymore.

[16:48:13.779] TypeError?: L.Hash is undefined

And the page's JS code is minified ... Could not find out a new EventListener? or something

comment:7 Changed 5 years ago by aseerel4c26

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Still a problem (with no workaround currently). Not every single map drag is a navigation action which would justify the cluttering of the user's browsing history.

Note: See TracTickets for help on using tickets.