Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#4949 closed defect (invalid)

"Share/HTML" for embedded maps escapes too much & in URL

Reported by: aseerel4c26 Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: Cc:

Description

all (multiple times in both URLs) & sequences should just be a &.

<iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="http://www.openstreetmap.org/export/embed.html?bbox=10.182781219482422%2C50.239629933632145%2C10.207414627075195%2C50.25711092263378&amp;layer=cyclemap&amp;marker=50.248371229685766%2C10.195097923278809" style="border: 1px solid black"></iframe><br/><small><a href="http://www.openstreetmap.org/?mlat=50.2484&amp;mlon=10.1951#map=15/50.2484/10.1951&amp;layers=C">View Larger Map</a></small>

Change History (3)

comment:1 Changed 6 years ago by jfire

&amp; is correct; & is invalid (though tolerated by many browsers).

http://www.w3.org/TR/html4/appendix/notes.html#h-B.2.2

comment:2 Changed 6 years ago by Tom Hughes

Resolution: invalid
Status: newclosed

comment:3 Changed 6 years ago by aseerel4c26

Thanks and sorry guys! That happens when you look for the cause of one problem and think you have found another (by seeing the uncommon URLs)... Hey, I even have tried them in my browser - in the URL bar, which did not work (of course it did not since it was no HTML)...

Note: See TracTickets for help on using tickets.