Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5011 closed defect (invalid)

$sudo bundle exec rake db:create - error

Reported by: achechet Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: Cc:

Description

I have got blank Ubuntu server 12.04.3 and try to install The Rails follow by Install.md from GitHub?. When I reach step with this command: $sudo bundle exec rake db:create I have recieved error: Couldn't create database for {"adapter"=>"postgresql", "encoding"=>"unicode", ... and so on... In Google search I have found recomendation like - put host: localhost and port: 5432 in config/database.yml. In my case it does not work. Have you any other advise or hints?

Change History (2)

comment:1 Changed 6 years ago by Tom Hughes

Resolution: invalid
Status: newclosed

This is (almost certainly) not a bug. If you need help setting up the rails server code then please ask on #osm-dev or on the dev or rails-dev mailing lists. It will be much easier to help you there than through a bug tracker.

comment:2 Changed 6 years ago by Andy Allan

I also should point out that nowhere does it say to run that command with sudo.

Note: See TracTickets for help on using tickets.