Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5014 closed task (invalid)

Your IP has been blocked

Reported by: jim@… Owned by: geocoding@…
Priority: minor Milestone: OSM 1.0
Component: nominatim Version: 1.0
Keywords: Cc:

Description

Received the following message

Your IP has been blocked. Please create a nominatim trac ticket (http://trac.openstreetmap.org/newticket?component=nominatim) to request this to be removed. Information on the Nominatim usage policy can be found here: http://wiki.openstreetmap.org/wiki/Nominatim#Usage_Policy

Not sure why as we use Google and MapQuest?.

We would appreciate if you would unblock our IP : 92.52.69.1

Change History (8)

comment:1 Changed 6 years ago by Tom Hughes

The problem is that IP belongs to a server farm rather than typical end user address space, and as such is a common source of spam.

Are you using a VPN provider or something?

comment:2 Changed 6 years ago by Tom Hughes

Component: adminnominatim
Owner: changed from Tom Hughes to geocoding@…

Oh hang on you're talking about nominatim, not the web site... I'll pass this over to the right people.

comment:3 Changed 6 years ago by jim@…

Our server is hosted on Rackspace but we've had it there for a couple of years.

The strange thing is that we don't use open street map directly due to limitations.

We use http://maps.googleapis.com/maps/api/geocode/xml?latlng= and http://open.mapquestapi.com/nominatim/v1/reverse?format=xml but looking at them now, it doesn't seem that we are blocked.

Strange!

Jim

comment:4 Changed 6 years ago by twain

Hi.

There is a block in the mapquest nominatim log for your ip on Wed, 09 Oct 2013 13:25:07 +0000. But only a single instance and nothing since. It has been automatically removed some time ago.

Can you provide the full request url you are using?

--

Brian

comment:5 Changed 6 years ago by Sarah Hoffmann

Resolution: invalid
Status: newclosed

As Brian said you should rather contact MapQuest? about your usage. The error message certainly did not come from the osm.org server as we have changed it to something different about 9 months ago.

Fixed the error message for blocked IPs in Nominatim, so that they do not get sent to this trac by default.

comment:6 Changed 6 years ago by jim@…

Guys,

Thanks again for the quick replies, this happening late on a Friday .... had me worried.

Just on geocoding - any recommendations of providers like MapQuest?? Either free or paid.

Jim

comment:7 Changed 6 years ago by Sarah Hoffmann

I'm not aware of any other providers for geocoding based on OSM data. If you produce enough traffic to run into MQ's usage limits you might actually want to consider running your own instance of Nominatim.

comment:8 Changed 6 years ago by jim@…

Isn't life strange, I'm only out of a team meeting where I've proposed exactly that! ;)

Note: See TracTickets for help on using tickets.