Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#5050 closed defect (fixed)

?bbox= links to osm.org no longer work

Reported by: Robert Whittaker Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: bbox, layers Cc:

Description

Previously, the following type of link would do what you would expect, ie show you a map zoomed in on the given bounding box: http://www.openstreetmap.org/?bbox=0.907561895561809,52.7108938152843,0.907561895561809,52.7108938152843

But since the launch of the recent redesign, these links seem to have stopped working. Instead, such links appear to display the last location that you viewed on OSM, much as if you'd just followed a link to http://www.openstreetmap.org/

Please restore the previous bbox functionality, to allow people to link to specific areas.

Change History (9)

comment:1 Changed 5 years ago by TomH

You can still link to a location, you just can't give a bounding box. We were aware of the loss of this functionality but analysis of server logs suggested that very few people were using it.

comment:2 Changed 5 years ago by Robert Whittaker

Even if not many people use it, it is arguably still a very useful feature to have. (It's lack of use was probably due to a lack of documentation.) As well as being able to link to an area, and guarantee that the area would be zoomed appropriately on an unknown screen size, the feature also allowed you to draw a box on the screen to outline an area. I have sites that used both of these features (one aimed at OSM mappers and one at the general public), and my links are now broken.

It appears that there is still code in place to allow the map to show and zoom to a particular bounding box, as it's used by the changeset view: http://www.openstreetmap.org/changeset/19211206 , just not to parse those particular URLs.

Is there are alternative URL format that will provide the functionality here (i.e. can I update my links to some other format)? Or has the code to interpret the URLs been removed altogether? If the latter, were there any particular reasons for doing so (i.e. would you be likely to accept a patch to restore it)?

comment:3 Changed 5 years ago by TomH

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 5 years ago by aseerel4c26

At least currently it works (partly) but does not show the bbox like before (a yellow/orange rectangle, IIRC). Example: http://www.openstreetmap.org/?box=yes&bbox=-4.269454,55.851998,-4.240465,55.864957 used in the description of https://wiki.openstreetmap.org/wiki/File:20130223_DSC1072_Looking_at_Buildings.jpg

comment:5 Changed 5 years ago by Robert Whittaker

Many thanks for the quick fix.

As you say, it's not completely fixed as there's no equivalent to &box=yes. I've also noticed that &layers=C is lost when the redirect happens, so there's no way to link to a specific bbox with a non-default different layer.

One of the links I was using that previously worked was http://www.openstreetmap.org/?minlon=0.8969&minlat=52.3616&maxlon=1.1020&maxlat=52.3865&layers=C&box=yes

I'm not against having to change the URL format to achieve it, but I would like to see the previous functionality made available again.

comment:6 Changed 5 years ago by Robert Whittaker

  • Keywords layers added
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:7 Changed 5 years ago by TomH

  • Resolution set to fixed
  • Status changed from reopened to closed

Well box=yes was only ever an internal implementation detail and was never intended for external use so I think it's highly unlikely we will bring that back.

In case the issue reported here (the bbox parameter) is clearly fixed.

comment:9 Changed 5 years ago by Robert Whittaker

The layers=* does indeed work again on the link I posted above, so that aspect is fixed, thanks.

Regarding the display of the bounding box, TomH, closed #5051 (which specifically mentioned the bounding box display) as a duplicate of this issue, but now says that bit isn't part of this issue! You can't have it both ways. :)

But for clarity (since the rest of #5051 has now been addressed), I've opened the lack of box display as a separate issue: #5060

Note: See TracTickets for help on using tickets.