Opened 5 years ago

Last modified 5 years ago

#5059 reopened defect

Remote edit links ignore shown object information ("browse" page)

Reported by: aseerel4c26 Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: edit remote_control Cc:

Description

http://www.openstreetmap.org/node/123456 misses the edit link for exactly this node. Only edit links for the whole area are available. This mostly concerns editing via JOSM. Before the UI change there was only THIS node loaded via remote control. Not possible anymore - or am I missing something?!

Impact: loading takes longer, consumes more resources on server and client and it takes longer for me to find the right object in the editor.

Change History (7)

comment:1 Changed 5 years ago by TomH

  • Resolution set to invalid
  • Status changed from new to closed

The edit button (and the entries in the edit menu) are all links to edit the specific node!

comment:2 Changed 5 years ago by TomH

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Summary changed from no edit links for single objects available anymore to Remote edit links ignore object information

Looks like you are right about the result (for remote edit only) just not about the cause.

It's not that the link isn't for the object, it's that the remote edit code is ignoring the informatin in the link.

comment:3 Changed 5 years ago by aseerel4c26

  • Keywords remote_control added

ah, thank you! In fact, I see it by hovering over the remote edit link. Yes, the remote edit does not work correctly.

Please note that it was not clear to me that the big edit button in fact changes - not related to the map display anymore but to the displayed object information. It should get another text then (to make this semantic change clear) - eg. "edit this object". If I remember correctly the old UI showed a clear description for those object edit links.

comment:4 Changed 5 years ago by aseerel4c26

  • Summary changed from Remote edit links ignore object information to Remote edit links ignore shown object information ("browse" page)

comment:5 Changed 5 years ago by TomH

I've applied a fix in 66aac9c/rails to pass the selection details to JOSM but it still downloads the whole area because we still pass the bounding box as well.

That doesn't seem to be any different to the old code though - as far as I can see we have always passed the bounding box as well as the selection. In fact I'm not even sure you can tell it to only fetch the object - the documentation is here:

http://wiki.openstreetmap.org/wiki/JOSM/Plugins/RemoteControl#load_and_zoom_command

and says that the "select" parameter controls what is selected, not what is downloaded. You still have to give a bounding box for the download.

comment:6 Changed 5 years ago by aseerel4c26

Oh, nice. I had a look, because I am not sure how it was:

At http://owl.apis.dev.openstreetmap.org/browse/node/89 the remote control link below the small map on the right (and also the edit link in the heading line - "node 89" and the edit link in the top menu) does call

GET http://127.0.0.1:8111/load_and_zoom?left=116.1222125&top=6.0116665&right=116.12241250000001&bottom=6.0114665&select=node89

which is a tiny bbox, yes . However, far less data than the big default viewport (maybe it was only like this because of the small map window on a object browse/detail page). AND the node gets selected (at least I think it was - the remote control from that page does not work for me (with those IDs and the default DB setup in JOSM). I think this should be findable in the old rails code.

Last edited 5 years ago by aseerel4c26 (previous) (diff)

comment:7 Changed 5 years ago by aseerel4c26

So, unless there will be another edit link (could be beneath the history link at the bottom of the sidepanel text) I think there is no possibility (UI-wise) for a smaller bounding box or a object-only download. A smaller bbox would be interesting if you want to edit a single node in a densely mapped city.

Object-only download to JOSM (could be interesting for geographically big ways or relations) is apparently only possible with the "import" command. Used by taginfo (via overpass api) and overpass turbo. Example link from taginfo: http://localhost:8111/import?url=http%3A%2F%2Foverpass-api.de%2Fapi%2Fxapi_meta%3F*%5Bbarrier%253Dpoller%5D

Note: See TracTickets for help on using tickets.