Opened 5 years ago

Closed 5 years ago

#5060 closed defect (duplicate)

Links to osm.org with a bbox and box=yes no longer draw the bounding box on the map

Reported by: Robert Whittaker Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: bbox Cc:

Description

Before the recent UI change, links such as http://www.openstreetmap.org/?minlon=0.8969&minlat=52.3616&maxlon=1.1020&maxlat=52.3865&layers=C&box=yes containing box=yes would display a yellow/orange rectangle on the screen corresponding to the bounding box given in the link.

The outline rectangle is no longer drawn. This functionality was useful for people wanting to provide a link to a specific area in a wider context, rather than just a single point. (The latter can be achieved with a marker positioned using mlat=* and mlon=* in the URL, but there's now no way to do the former.) The loss of this functionality will degrade the value of existing bookmarks and links that people have created. It will also make linking to OSM less favourable, loosing us valuable exposure. Therefore the functionality should be restored.

The ability to draw such boxes on the map is still present in the code (e.g. in the changeset and history views) so it should just be a matter of interpreting the box=yes part of URL.

Change History (1)

comment:1 Changed 5 years ago by TomH

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5055.

Note: See TracTickets for help on using tickets.