Opened 5 years ago

Closed 5 years ago

#5096 closed defect (fixed)

dropdown usermenu overflow issue

Reported by: Aerilius Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: Cc:

Description

After creating an account on http://www.openstreetmap.org, the dropdown usermenu shows a long urlencoded path string so that the button covers almost the whole browser width. This is probably because a new user does not yet have a profile image.

Expected behavior: The path string would not be visible, no profile image or a default avatar would be displayed.

Browser: Firefox 26.0

Operating System: Ubuntu 13.10

Attachments (2)

osm dropdown usermenu(1).png (65.1 KB) - added by Aerilius 5 years ago.
osm dropdown usermenu(2).png (55.5 KB) - added by Aerilius 5 years ago.
http://www.openstreetmap.org/user/<username>

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by Aerilius

comment:1 Changed 5 years ago by Aerilius

What I reported above is with what a new user was greeted without going through the available settings. I just found that disabling Gravatar works around the issue (which was preselected). Apart from that it could be thought whether to use Gravatar only without the user's consent.

comment:2 Changed 5 years ago by Tom Hughes

This shouldn't happen because gravatar should redirect back to the osm URL that we pass as the default, which will then display the default image.

If you look at the image you posted you'll see there is a d= parameter in the link text, which is the URL it should have redirected back to, and testing here seems to show it working for me...

comment:3 Changed 5 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

I've pushed 67dbde0/rails to stop the long URL displaying if something goes wrong.

Note: See TracTickets for help on using tickets.