Opened 5 years ago

Closed 5 years ago

#5118 closed defect (fixed)

Cannot upload in HTTPS with OAuth

Reported by: don-vip Owned by: rails-dev@…
Priority: major Milestone:
Component: api Version:
Keywords: oauth https Cc:

Description

Hi,

We have enabled HTTS support towards OSM API in latest JOSM (see #josm9710).

It works great with basic authentication, bur for some reason it fails with OAuth with HTTP 401:

INFO: PUT https://api.openstreetmap.org/api/0.6/changeset/create... 
INFO: OK
INFO: POST https://api.openstreetmap.org/api/0.6/changeset/20532333/upload... 
INFO: Authorization Required
ERROR: Error body: Couldn't authenticate you
ERROR: org.openstreetmap.josm.io.OsmApiException: ResponseCode=401, Error Body=<Couldnt authenticate you>

It looks like there's a problem on server side ?

Change History (5)

comment:1 Changed 5 years ago by Tom Hughes

Well the PUT worked, and that requires authentication.

comment:2 Changed 5 years ago by Dirk Stoecker

BTW there is a typo: "Couldnt".

comment:3 Changed 5 years ago by Tom Hughes

I have now tried (on my local instance) both Potlatch 2 and iD using oauth over https and both seem to be working.

My suspicion is that it's likely JOSM is somehow computing the oauth signature wrongly for POST requests over https.

comment:4 Changed 5 years ago by don-vip

OK thanks for the test, we're investigating to see if would not be a bug in our OAuth Java library.

comment:5 Changed 5 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

It turned out this was a problem with our production environment that didn't occur in a test environment, and I think it should be fixed now.

Note: See TracTickets for help on using tickets.