Opened 4 years ago

Closed 3 weeks ago

#5119 closed enhancement (fixed)

Going from a nominatim result to corresponding osm.org map.

Reported by: Papou Owned by: geocoding@…
Priority: trivial Milestone:
Component: nominatim Version: 2.0
Keywords: Cc:

Description

There is no apparent way to go from a http://nominatim.openstreetmap.org/search.php? result to the corresponding plain osm.org map.

Change History (7)

comment:1 Changed 4 years ago by floscher

  • Priority changed from major to trivial
  • Resolution set to fixed
  • Status changed from new to closed

Just click on "(details)" in a result-item. On the Details-page you will find a link to osm.org
There are even links to the "parents" and the "children" of the found element.

In my opinion this is apparent enough.

comment:2 Changed 4 years ago by lonvia

  • Resolution fixed deleted
  • Status changed from closed to reopened

Not really the same thing. Occasionally it would be handy to go to the osm.org page with the same map view, for example, in order to open the data browse layer.

comment:3 Changed 4 years ago by floscher

Then click on "(details)". This takes you to the details page.

For the search term "London", this is http://nominatim.openstreetmap.org/details.php?place_id=97592906.

On that page you will find the line:

OSM: relation 65605

Isn't that exactly what you want?

comment:4 Changed 4 years ago by lonvia

Agreed, there are many ways to get approximately the same map view but they are all annoyingly complicated. I agree with the original reporter that it would be so much more convenient to have a direct link. Also, it would be neither very intrusive nor hard to implement.

comment:5 Changed 4 years ago by floscher

  • Type changed from defect to enhancement

Yes, it is not hard to implement and it would not bother me, if someone would implement the functionality you suggest.

But: In my opinion it is not the purpose of the nominatim website to link to the osm.org main website, because it has its own visualization of the results (and the link to osm.org mentioned above).

If I want the osm.org map view as a result, I would use the search of the osm.org page, which also uses the nominatim geocoder, not the website on http://nominatim.openstreetmap.org/search.php.

comment:6 Changed 4 years ago by Papou

@Lonvia: Nice to see you here! You have indeed understood what I meant with *plain* plain osm.org map.
I had indeed found how to finally get to a plain OSM map, but it's hard to remember all those winding little passages ;-) and other persons might give up.

@floscher: the problem is that the Nominatim page contains options not found on OSM but that if you want to share its result without drowning normal people under Nominatim, you'd better send them the OSM.org URL for an ever improving page with final user features.

A canonical process (but I'm not going to request that) would be to have a "Nominatim helper" function in OSM.org; the OSM.org map would be displayed on exit from Nominatim and the same process would be usable from any kind of map.

comment:7 Changed 3 weeks ago by lonvia

  • Resolution set to fixed
  • Status changed from reopened to closed

Works now. Click on 'show map bounds' and there is a link there.

Note: See TracTickets for help on using tickets.