Opened 5 years ago

Closed 5 years ago

#5169 closed defect (invalid)

overpass export doesn't return complete relations

Reported by: Graham Asher Owned by: rails-dev@…
Priority: major Milestone:
Component: website Version:
Keywords: overpass, OSM Cc:

Description

Exporting OSM data using the Overpass API from the main map page doesn't complete all relations for objects overlapping the bounding box. For example, a map of Stockholm created in this way lacks Lake Mälar (Mälaren) to the west.

To reproduce, export the following rectangle: (W,S,E,N): 17.8,59.2,18.3,59.5 and convert it to a map (I use CartoType? but anything will do).

Here is a proposed fix. Use this Overpass script as recommended by the Overpass development team:

<osm-script timeout="10000" element-limit="1073741824">

<union into="_">

<bbox-query into="_" w="17.8" s="59.2" e="18.3" n="59.5"/> <recurse from="_" into="_" type="up"/> <recurse from="_" into="_" type="down"/>

</union> <print from="_" limit="" order="id"/>

</osm-script>

It completes all relations, and solves the problem, as verified by my testing.

Change History (1)

comment:1 Changed 5 years ago by drolbr

Resolution: invalid
Status: newclosed

I'll move this bug to https://github.com/drolbr/Overpass-API/issues/88 because rails-dev calls /api/map and the resolving of what to fetch precisely is done there.

It can be closed here.

Note: See TracTickets for help on using tickets.