Opened 5 years ago

Closed 5 years ago

#5195 closed defect (worksforme)

Bad address shown when searched by nominatim

Reported by: branek Owned by: geocoding@…
Priority: major Milestone:
Component: nominatim Version:
Keywords: Cc: branko.karaklajic@…

Description

  • Bug

Bad address shown when searched by nominatim. Not consistent with Open Street Map data.

  • Steps to reproduce:

Go to nominatim http://nominatim.openstreetmap.org

Select highlight, and in search field input: Karađorđeva 154a, Užice

  • Current behavior:

You will get one result, and correctly selected house but address is wrong.

154A, Карађорђева, САЛОН НАМЕШТАЈА -* ФОРМА ИДЕАЛЕ, Krcagovo, Uzice, Uzice City, Zlatibor District, Sumadija and Western Serbia, Central Serbia, 31103, Serbia

  • Correct behavior:

154A, Карађорђева, Krcagovo, Uzice, Uzice City, Zlatibor District, Sumadija and Western Serbia, Central Serbia, 31103, Serbia

Description: If you click on details to show how address is generated you will get:

154A

Name:
Type: place:house
Last Updated: 2013-03-29 11:15
Admin Level: 15
Rank: Other: 30
Coverage: Polygon
Centre Point: 43.85854555,19.8573324873446
OSM: way 213227772
Extra Tags:
Address

154A (Type: place:house_number, 0 GOTO)
Карађорђева (Type: highway:living_street, way 65635931, 15, 0 GOTO)
САЛОН НАМЕШТАЈА -* ФОРМА ИДЕАЛЕ (Type: landuse:residential, way 154354128, 15, 0.0126489106298015 GOTO)
Krcagovo (Type: place:suburb, node 910535072, 15, 0.00933890557024875 GOTO)
Uzice (Type: place:city, node 848084912, 100, 0.0168473552945262 GOTO)
Uzice City (Type: boundary:administrative, relation 2872863, 7, 0.124210810640902 GOTO)
Zlatibor District (Type: boundary:administrative, relation 2114084, 6, 0.25537075238196 GOTO)
Sumadija and Western Serbia (Type: boundary:administrative, relation 2959530, 5, 0.464596138402977 GOTO)
Central Serbia (Type: boundary:administrative, relation 1658166, 4, 1.22258931627831 GOTO)
31103 (Type: place:postcode, 0 GOTO)
31000 (Type: place:postcode, 0.0150952189967305 GOTO)
Serbia (Type: place:country, relation 3086184, 2, 0.964288459468689 GOTO)
Serbia (Type: place:country, relation 1741311, 2, 0.964358755174647 GOTO)
rs (Type: place:country_code, 0 GOTO)

If you click on goto for the record:

САЛОН НАМЕШТАЈА -* ФОРМА ИДЕАЛЕ (Type: landuse:residential, way 154354128, 15, 0.0126489106298015 GOTO)

You are not able to find any definition of "САЛОН НАМЕШТАЈА -* ФОРМА ИДЕАЛЕ"

Change History (1)

comment:1 Changed 5 years ago by Sarah Hoffmann

Resolution: worksforme
Status: newclosed

Looks like way 154354128 has been successfully removed now from Nominatim's DB. At least the road above looks ok for me.

Note: See TracTickets for help on using tickets.