Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#5204 closed defect (wontfix)

i18n: FR / Error message translation mistake in /account

Reported by: gaspard Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: i18n, fr Cc:

Description

In the account page (https://www.openstreetmap.org/user/someusername/account ), when changing your display name, if the wished display name is not available, an error message will appear.

In English it should be "Display name not available" which has been translated by "Affichage du nom non disponible" which is a bad translation because it means "Displaying this name is not doable".

I would recommend: "Pseudonyme non disponible".

---

How to reproduce: 1 Invite some french speaking friend, 2 open a bottle of red wine, 3 ask your french speaking friend to connect on osm with his french settings 4 ask him to change his display name to some unavailable one 5 discuss about subtlety and refinement of french language while drinking the red wine.

Change History (3)

comment:1 Changed 5 years ago by Shaun McDonald

Resolution: wontfix
Status: newclosed

comment:2 Changed 5 years ago by gaspard

changeset [77e726d] (https://trac.openstreetmap.org/changeset/77e726d5ab94bb82ba2af896ec1a4f7c4cacc36c/rails) includes a false translation by Mulcyber. The trouble with thanslatewiki is that there is no context.

"Display name" can mean :

  • the action to show a name, like "drink beer"
  • the displayed name, like "blue car"

This is the old "open door" MUD game translation mistake: do we translate by "to open the door" or "opened door" ?

Is the "Display name" locale used in the 2 different contexts ?

comment:3 Changed 5 years ago by Tom Hughes

In the context of OSM it is always going to mean the username.

Note: See TracTickets for help on using tickets.