Opened 12 years ago

Closed 12 years ago

#521 closed defect (fixed)

Render names on areas, and for all nodes

Reported by: tom@… Owned by: Tom Hughes
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

There are two problems with name rendering at the moment.

First, areas don't get named, which leads people to add nodes in the middle of them with the name. This covers all sorts of features where the area at least gets rendered like parks, supermarkets and schools, as well as areas that aren't currently rendered at all, like hospitals.

Second, even with nodes the names don't always show up consistently. In the following map, for example, the "Amott Road Baptist Church" gets named at levels 17 and 18, but no other churches in the area are that priveleged: http://www.openstreetmap.org/?lat=51.464552924485&lon=-0.07433913392533095&zoom=17

I can't see any reason for this, like roads or other features being in the way, or bad tagging. Given that pub names show up consistently and rather well I also assume it's not a bug in mapnik.

Having names on the maps makes them ten times more useful!

Change History (1)

comment:1 Changed 12 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

Areas do now get names, although there are some positioning issues which are down to mapnik. The churches with no names are just down to mapnik thinking there isn't space I think - the names are definitely present in the database mapnik is rendering from.

Note: See TracTickets for help on using tickets.