Opened 5 years ago

Closed 5 years ago

#5234 closed defect (duplicate)

tunnel=* on a way generates inappropriate address/place

Reported by: skybunny Owned by: geocoding@…
Priority: minor Milestone:
Component: nominatim Version:
Keywords: tunnel, waterway Cc:

Description

Consider placeid https://nominatim.openstreetmap.org/details.php?place_id=9212214461 ...

Two issues seem evident; the first is how nominatim is handling address generation for ways with the tag tunnel=* regardless of other tagging; the second is that it is generating them for a waterway way at all.

Issue A: For ways with tunnel=* in general, the address 'West Pine Lake Road, Atkins, Forest, Wisconsin, United States of America' is generated. I would expect that a generated address in this case should be 'Atkins, Forest, Wisconsin, United States of America', as a tunnel does not necessarily have anything to do with the closest way of type 'highway'.

Issue B: Regardless of (A), above, this is a way of type waterway=*, which in turn is a member of a relation of type waterway=*. Generally these do not generate a placeid at all, because they are parented to the waterway relation (here, relation 172143.) In other words, that the way has the waterway tag on it should be evaluated over the fact that tunnel also does.

Thanks for the consideration!

Change History (1)

comment:1 Changed 5 years ago by Sarah Hoffmann

Resolution: duplicate
Status: newclosed

For issue A, I tend to disagree. There can be quite a lot of tunnels in a town and getting a more specific address that includes a street name can only help to disambiguate results.

Regarding issue B, the problem is that the name tag which actually refers to the stream is taken to belong to the tunnel. To fix that Nominatim neds to interpret bridge:name and tunnel:name. That is already covered in #4361, so closing this one as a duplicate.

Note: See TracTickets for help on using tickets.