Opened 5 years ago

Closed 5 years ago

#5251 closed defect (invalid)

error reverse geocoding osm_id using nominatim

Reported by: t_cmore Owned by: geocoding@…
Priority: major Milestone:
Component: nominatim Version:
Keywords: osm_id, geocode Cc:

Description

the reverse gecodeing of an osm id is not possabily at the moment. when i send the following request: http://nominatim.openstreetmap.org/reverse?format=json&osm_type=W&osm_id=182332025

i get this error: Unable to geocode

i also tried it with other valid osm_id, but each time i get the same error. Three weeks ago evrything works fine.

Change History (2)

comment:1 Changed 5 years ago by Sarah Hoffmann

osm_id geocoding is working fine, e.g. http://nominatim.openstreetmap.org/reverse?format=json&osm_type=W&osm_id=210534388

The way you are referencing is simply not in the database, possibly because it doesn't have a name.

comment:2 Changed 5 years ago by Sarah Hoffmann

Resolution: invalid
Status: newclosed

I've confirmed in the code that unnamed minor highways are ignored. This is not a regression, it has always been that way.

Minor highways are the following: service, cycleway, path, footway, steps, bridleway, track, byway, motorway_link, primary_link, trunk_link, secondary_link, tertiary_link

Note: See TracTickets for help on using tickets.