Opened 5 years ago

Closed 5 years ago

#5257 closed defect (invalid)

SVG support is broken

Reported by: don-vip Owned by: Grant Slater
Priority: minor Milestone:
Component: wiki Version:
Keywords: svg Cc:

Description

See https://wiki.openstreetmap.org/wiki/File:JOSM_new_logo.svg

I don't have any problem with recent browsers nor Inkscape. The SVG library used by the wiki must be outdated.

Change History (3)

comment:1 Changed 5 years ago by Tom Hughes

Priority: majorminor

You haven't told anybody what is actually wrong... If you are claiming that it is rendered wrong then it would be helpful if you provided a comparison that shows what it should look like otherwise nobody will know whether they have fixed it.

That said it's highly unlikely that any libraries will be updated - the machine is running the current libraries from Ubuntu and is updated at least once a week normally.

At some point it will likely be updated from Ubuntu 12.04 to 14.04 but if the logo is really using such obscure SVG features that Ubuntu 12.04 can't render it right then you may want to find a better way to do whatever it is you're doing.

comment:2 Changed 5 years ago by Tom Hughes

Oh and for the record, the rendered PNG that I get from the wiki looks (as far as I can see) the same as what Firefox produces when I look at the SVG directly.

comment:3 Changed 5 years ago by don-vip

Resolution: invalid
Status: newclosed

Sorry it looks it was a bug in the SVG file after all as we now have a corrected version.

I don't know what was wrong that was why we made a logo contest, I'm not a graphist at all :)

Note: See TracTickets for help on using tickets.