Opened 4 years ago

Closed 4 years ago

#5274 closed defect (fixed)

Housenumbers containing a dash are not found

Reported by: richardbrinkman Owned by: geocoding@…
Priority: minor Milestone:
Component: nominatim Version:
Keywords: Cc:

Description

A housenumber in OSM may contain letters, dashes or other characters (source: http://wiki.openstreetmap.org/wiki/Key:addr:housenumber). However Nominatim cannot always find address nodes containing a dash.

It will not find "Goedestraat 41-BS, Utrecht", although this node does exist: http://www.openstreetmap.org/node/2679526109

It seems like it cannot find such addresses if the part after the dash are letters; if it contains another number it will find the address. For example "S.L. Louwesstraat 2-37, Enschede" correctly resolves to http://www.openstreetmap.org/node/2744509276.

Both addresses should be treated the same way: "building# dash appartment#"

Change History (3)

comment:1 Changed 4 years ago by Sarah Hoffmann

This is not directly related to the dash. The address is found when the query is 41-BS, Goedestraat, Utreecht.

The searches with a search group are ordered badly. The ones with the fewest search terms should come first, they seem to be last right now.

comment:2 Changed 4 years ago by Sarah Hoffmann

Also it looks like the preference of having countries at the end of the search term does no longer work correctly. Most probably a regression from e16fcf8/nominatim.

comment:3 Changed 4 years ago by Sarah Hoffmann

Resolution: fixed
Status: newclosed

Fixed the regression with country names which fixes the issue with this address.

Note: See TracTickets for help on using tickets.