Opened 4 years ago

Closed 4 years ago

#5309 closed defect (duplicate)

Searching for address returns result - adding postcode to address finds nothing

Reported by: flohoff Owned by: geocoding@…
Priority: minor Milestone:
Component: nominatim Version:
Keywords: postcode Cc:

Description

Hi,

i am looking for the Address of "Flora 3, 55459 Grolsheim" which is an isolated_dwelling. The Address uses addr:place.

Searching for Flora 3, Grolsheim works and returns:

Name:Flora (name) Type: place:isolated_dwelling Last Updated: 2015-04-17 13:21 Admin Level: 15 Rank: Suburb Importance: 0.25 (estimated) Coverage: Polygon Centre Point: 49.91711235,7.90979214158921 OSM: way 329099739

Extra Tags: Address Flora (Type: place:isolated_dwelling, way 329099739, 15, 0 GOTO) Grolsheim (Type: place:village, relation 1245778, 8, 0.0133198388358754 GOTO) Sprendlingen-Gensingen (Type: boundary:administrative, relation 660347, 7, 0.0793508988616036 GOTO) Landkreis Mainz-Bingen (Type: boundary:administrative, relation 62632, 6, 0.169435838984687 GOTO) Rhineland-Palatinate (Type: place:state, relation 62341, 4, 0.460738825803487 GOTO) Germany (Type: place:country, relation 51477, 2, 2.82851660721372 GOTO) de (Type: place:country_code, 0 GOTO)

Adding the postcode of 55459 returns nothing.

Change History (2)

comment:1 Changed 4 years ago by flohoff

I am sorry - the correct result i get is:

3 Name: Type: building:yes Last Updated: 2015-04-17 13:21 Admin Level: 15 Rank: Other: 30 Coverage: Polygon Centre Point: 49.9168821,7.9107801 OSM: way 329101671 Extra Tags: Address 3 (Type: place:house_number, 0 GOTO) Flora (Type: place:isolated_dwelling, way 329099739, 15, 0 GOTO) Grolsheim (Type: place:village, relation 1245778, 8, 0.0133198388358754 GOTO) Sprendlingen-Gensingen (Type: boundary:administrative, relation 660347, 7, 0.0793508988616036 GOTO) Landkreis Mainz-Bingen (Type: boundary:administrative, relation 62632, 6, 0.169435838984687 GOTO) Rhineland-Palatinate (Type: place:state, relation 62341, 4, 0.460738825803487 GOTO) 55459 (Type: place:postcode, 0 GOTO) Germany (Type: place:country, relation 51477, 2, 2.82851660721372 GOTO) de (Type: place:country_code, 0 GOTO)

The postcode returned by this search is 55459 - adding this to the search term - e.g.

55459 Grolsheim, Flora 3

returns the dwelling - not the house:

Flora Name: Flora (name) Type: place:isolated_dwelling Last Updated: 2015-04-17 13:21 Admin Level: 15 Rank: Suburb Importance: 0.25 (estimated) Coverage: Polygon Centre Point: 49.91711235,7.90979214158921 OSM: way 329099739 Extra Tags: Address Flora (Type: place:isolated_dwelling, way 329099739, 15, 0 GOTO) Grolsheim (Type: place:village, relation 1245778, 8, 0.0133198388358754 GOTO) Sprendlingen-Gensingen (Type: boundary:administrative, relation 660347, 7, 0.0793508988616036 GOTO) Landkreis Mainz-Bingen (Type: boundary:administrative, relation 62632, 6, 0.169435838984687 GOTO) Rhineland-Palatinate (Type: place:state, relation 62341, 4, 0.460738825803487 GOTO) Germany (Type: place:country, relation 51477, 2, 2.82851660721372 GOTO) de (Type: place:country_code, 0 GOTO) Parent Of: Building 3 (Polygon, ~0 miles, way 329101671, GOTO)

comment:2 Changed 4 years ago by Sarah Hoffmann

Resolution: duplicate
Status: newclosed

Duplicate of #2497.

There really should be an FAQ about searching for postcodes.

Note: See TracTickets for help on using tickets.