Opened 4 years ago

Last modified 4 years ago

#5342 new defect

Routing will not accept destination entry under certain circumstances.

Reported by: stanton Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: routing, Firefox Cc: stanton

Description

For a few weeks I've now been experiencing issues with the routing feature on the OSM home page.

Steps to reproduce:

  • Click the Routing button (arrow icon).
  • Enter start position (in my case, I could select the address from the history afrer entering a few characters).
  • Enter the destination. In my case, the history list will pop up after a few characters but around the same time I will get a JavaScript? alert "Sorry – couldn't find that place". After clicking OK, I can complete my destination entry and click "Go", but nothing happens and no route is calculated.

If go directly to a routing URL (e.g. http://www.openstreetmap.org/directions?engine=mapquest_car&route=60.2963%2C25.0394%3B60.2955%2C25.0448#map=16/60.2971/25.0374&layers=Q), the route is displayed, hence it is apparently the input form that is not working.

I have tried this on four different machines:

  • Machine 1: Ubuntu MATE 14.10, Firefox 39, no proxy – DOESN'T WORK.
  • Machine 2: Ubuntu MATE 15.04, Firefox 39 or 40 (iirc), no proxy – DOESN'T WORK.
  • Machine 3: Kubuntu 12.04-based, old Firefox (not sure about version), behind proxy – WORKS.
  • Machine 4: Ubuntu 12.04, Firefox 25, no proxy – WORKS.

I remember that routing worked from Machine 1 around May (most likely on an earlier Firefox version), thus I suspect either an update on OSM or on the PCs (most likely the browser) broke things.

Change History (1)

comment:1 Changed 4 years ago by stanton

Cc: stanton added
Note: See TracTickets for help on using tickets.