Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#5381 closed enhancement (fixed)

OTRS does not send email to mail addresses with no MX address

Reported by: SomeoneElse Owned by: Tom Hughes
Priority: minor Milestone:
Component: admin Version:
Keywords: Cc:

Description

(for an example problem email address, see the first article on OTRS DWG ticket 2015112810000032)

OTRS displays the message "this email failed MX check". It's correct in that there is no MX, and it's the user's config that's the problem, but it'd be nice if OTRS could fall back to using the A record (which is I suspect where their home mail server lives).

It's an enhancement rather than a bug, but a fix would save having to email directly via my ISP and then copy and paste manually into OTRS.

Change History (6)

comment:1 Changed 4 years ago by Tom Hughes

Well I really hope OTRS isn't sending email directly at all!

It should be handing it off to exim, and I'm pretty sure that will get this right.

comment:2 Changed 4 years ago by Tom Hughes

I don't see a bounce message anywhere on that ticket? Which message number is it?

comment:3 Changed 4 years ago by Tom Hughes

As I thought, it sends email though exim, but I see no sign of any emails to the user on that ticket, nor can I see any bounce message so I've no idea what it was you saw but there's no problem I can see.

comment:4 Changed 4 years ago by Tom Hughes

Most of those messages are months old though, so any logs are long gone!

comment:5 Changed 4 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

So it seems that for some reason OTRS has an internal check which I assume is what you were seeing, before it even tries the email.

I have no idea what the point of that is, especially when it's broken, but I hope I've turned it off now.

comment:6 Changed 4 years ago by SomeoneElse

Yes - just tried the problem address again and it's worked, thanks.

Note: See TracTickets for help on using tickets.