Opened 4 years ago

Closed 4 years ago

#5390 closed defect (invalid)

lot of timeouts / very slow API

Reported by: malenki Owned by: rails-dev@…
Priority: major Milestone:
Component: api Version:
Keywords: Cc:

Description

Using the OSM API since several weeks I get often repeated timeouts for down- or uploads Using JOSM to the point where it affects seriously my will to contribute to OSM.

Sometimes I get five timeouts in a row when trying just to open one object.

Downloads with wget are affected, too (have a look below). Access to the website itself works fine.

Until another person reported the same issue on IRC¹ I thought it may be just a problem in my local setup somewhere but finally I dared to report this.

I would be very glad if this behaviour would be fixed.

¹ in #openstreetmap on freenode on 2016-02-24: [21:10:41] <F6F> Hi im facing a ugly issue with my josm [21:12:08] <F6F> each time I try to upload changes I get an api error stream closed [21:14:16] <F6F> my connection to https://www.openstreetmap.org/ works without any issues :-(

time wget http://www.openstreetmap.org/api/0.6/changeset/37377131/download
--2016-02-24 22:11:03--  http://www.openstreetmap.org/api/0.6/changeset/37377131/download
Auflösen des Hostnamens »www.openstreetmap.org (www.openstreetmap.org)« … 2001:630:12:500:219:bbff:fe39:3d9e, 2001:630:12:500:219:bbff:fe39:8aba, 2001:630:12:500:21a:4bff:fea5:fd2a, ...
Verbindungsaufbau zu www.openstreetmap.org (www.openstreetmap.org)|2001:630:12:500:219:bbff:fe39:3d9e|:80 … fehlgeschlagen: Die Wartezeit für die Verbindung ist abgelaufen.
Verbindungsaufbau zu www.openstreetmap.org (www.openstreetmap.org)|2001:630:12:500:219:bbff:fe39:8aba|:80 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 200 OK
Länge: nicht spezifiziert [text/xml]
Wird in »»download.3«« gespeichert.

download.3                                 [ <=>                                                                         ]  30,29K  --.-KB/s    in 0,04s   

2016-02-24 22:13:10 (738 KB/s) - »download.3« gespeichert [31019]


real	2m7.780s
user	0m0.003s
sys	0m0.003s

time wget http://www.openstreetmap.org/api/0.6/changeset/37377131/download
--2016-02-24 22:13:26--  http://www.openstreetmap.org/api/0.6/changeset/37377131/download
Auflösen des Hostnamens »www.openstreetmap.org (www.openstreetmap.org)« … 2001:630:12:500:219:bbff:fe39:3d9e, 2001:630:12:500:21a:4bff:fea5:fd2a, 2001:630:12:500:219:bbff:fe39:8aba, ...
Verbindungsaufbau zu www.openstreetmap.org (www.openstreetmap.org)|2001:630:12:500:219:bbff:fe39:3d9e|:80 … fehlgeschlagen: Die Wartezeit für die Verbindung ist abgelaufen.
Verbindungsaufbau zu www.openstreetmap.org (www.openstreetmap.org)|2001:630:12:500:21a:4bff:fea5:fd2a|:80 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 200 OK
Länge: nicht spezifiziert [text/xml]
Wird in »»download.4«« gespeichert.

download.4                                 [ <=>                                                                         ]  30,29K  --.-KB/s    in 0,04s   

2016-02-24 22:15:34 (713 KB/s) - »download.4« gespeichert [31019]


real	2m7.746s
user	0m0.003s
sys	0m0.003s

time wget http://www.openstreetmap.org/api/0.6/changeset/37377131/download
--2016-02-24 22:15:42--  http://www.openstreetmap.org/api/0.6/changeset/37377131/download
Auflösen des Hostnamens »www.openstreetmap.org (www.openstreetmap.org)« … 2001:630:12:500:219:bbff:fe39:3d9e, 2001:630:12:500:21a:4bff:fea5:fd2a, 2001:630:12:500:219:bbff:fe39:8aba, ...
Verbindungsaufbau zu www.openstreetmap.org (www.openstreetmap.org)|2001:630:12:500:219:bbff:fe39:3d9e|:80 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 200 OK
Länge: nicht spezifiziert [text/xml]
Wird in »»download.5«« gespeichert.

download.5                                 [ <=>                                                                         ]  30,29K  --.-KB/s    in 0,04s   

2016-02-24 22:15:42 (716 KB/s) - »download.5« gespeichert [31019]


real	0m0.402s
user	0m0.000s
sys	0m0.007s

Change History (4)

comment:1 Changed 4 years ago by malenki

Summary: lot of timeoutslot of timeouts / very slow API

comment:2 Changed 4 years ago by Tom Hughes

I'm sure you would be glad if it was fixed, and if it is a problem at our end then we'd love to fix it.

Unfortunately on the basis of this report there's very little we can do. I'm not doubting that what you're seeing is real, but unless it happens to me in a reproducible way then there's not much I can do.

Given that nobody else has reported similar problems it's very likely that it's a network issue somewhere closer to you and outside our control anyway.

comment:4 Changed 4 years ago by malenki

Resolution: invalid
Status: newclosed

Indeed it seems to be a buggy IPv6 although I didn't bother with it (except the usual software updates). Disabling IPv6 helps solving the issue. Sorry for bothering you.

Note: See TracTickets for help on using tickets.