Opened 12 years ago

Closed 12 years ago

#543 closed defect (fixed)

Empty "upload GPX file" box on upload page does not give meaningful error

Reported by: openstreetmap@… Owned by: Tom Hughes
Priority: major Milestone:
Component: website Version:
Keywords: gpx trace upload Cc:

Description

On the GPX upload page (http://www.openstreetmap.org/traces/mine), if the "description" or "tags" box is empty, it returns an error. But, if the "Upload GPX File" box is empty (as it defaults to when this error appears), the following message appears:

Application error

Change this error message for exceptions thrown outside of an action (like in Dispatcher setups or broken Ruby code) in public/500.html

This appears to be a default Ruby error message - would be better to give the user a meaningful error message.

Also, would be better if the "Upload GPX File" box on the error page was already populated, or it was highlighted to make it obvious that the file needed to be re-selected.

Change History (4)

comment:1 Changed 12 years ago by Tom Hughes

Component: datasourceswebsite
Owner: changed from mikel_maron@… to Tom Hughes

Umm... how could it be populated on the error page? are we supposed to guess what the name of your trace file is?

Obviously the 500 error is something that needs fixing - I suspect I know what the cause is and I'll try and look at it later on along with your other bug.

comment:2 Changed 12 years ago by Tom Hughes

Oh - I see what you mean - you want it populated on the original error page when there was no description. That might be hard, because I'm not sure if the browser sends the full pathname when doing a file upload (to be honest, it probably shouldn't from a security point of view).

comment:3 Changed 12 years ago by openstreetmap@…

I wasn't sure if the file name could be populated on the error page or not. I don't see that as a big issue, but I'd highlight the file box as well as the description box, so that it's obvious to the user that they have to re-enter the file name. Otherwise most people will just add a description and then get an error because there's no file name (that's what I did)

comment:4 Changed 12 years ago by tomhughes

Resolution: fixed
Status: newclosed

(In [4709]) Improve consistency of trace upload forms and error handling.

Fixes #543 and #544.

Note: See TracTickets for help on using tickets.