#5440 closed defect (invalid)

Fails to build with JDBC 9.4 (PGObject class removed)

Reported by: sebastic Owned by: brett@…
Priority: major Milestone:
Component: osmosis Version:
Keywords: jdbc Cc: sebastic

Description

The PGHStore class causes a build failure with the latest PostgreSQL JDBC driver (9.4-1212) as reported by Lucas Nussbaum in Debian Bug #850993:

/<<PKGBUILDDIR>>/osmosis-hstore-jdbc/src/main/java/org/openstreetmap/osmosis/hstore/PGHStore.java:36: error: package org.postgresql.util does not exist
import org.postgresql.util.PGobject;
                          ^
/<<PKGBUILDDIR>>/osmosis-hstore-jdbc/src/main/java/org/openstreetmap/osmosis/hstore/PGHStore.java:42: error: cannot find symbol
public class PGHStore extends PGobject implements Serializable, Cloneable, Map<String, String>
                              ^
  symbol: class PGobject
/<<PKGBUILDDIR>>/osmosis-hstore-jdbc/src/main/java/org/openstreetmap/osmosis/hstore/PGHStore.java:52: error: cannot find symbol
        setType("hstore");
        ^
  symbol:   method setType(String)
  location: class PGHStore
3 errors
1 warning
:osmosis-hstore-jdbc:compileJava FAILED

This issue will cause the removal of the osmosis package from the upcoming Debian stable release (stretch).

Change History (1)

comment:1 Changed 22 months ago by sebastic

  • Resolution set to invalid
  • Status changed from new to closed

Sorry for the noise, this was a false positive. I overlooked the groupId change in the updated postgresql-jdbc package which was the cause for the PGobject class not being found.

Note: See TracTickets for help on using tickets.