Opened 6 months ago

Last modified 3 months ago

#5457 new defect

Potlatch P2 crashes Flash, mousewheel zoom not working, in Firefox 54 on Linux

Reported by: Cebderby Owned by: potlatch-dev@…
Priority: critical Milestone:
Component: potlatch2 Version:
Keywords: Cc:

Description

In Firefox 54, Potlatch crashes Flash plugin simply by clicking anywhere not on an object, making editing effectively impossible.
Also mouse wheel zoom does nothing (+/- buttons in top left corner work fine).
Second user confirms, both running Linux (Mint 17.3, Ubuntu 16) with Firefox version 54 (64 bit).
Did try Flash plugin version 25.0 (which used to be fine), that makes no difference to the problems, same as latest 26.0
Reportedly ok in Chrome, so looks like change to Firefox 54 has triggered this.

Change History (7)

comment:1 Changed 6 months ago by Cebderby

(perhaps component should be set to 'potlatch2' - please move/change if more appropriate)

comment:2 Changed 6 months ago by Richard

  • Component changed from potlatch (flash editor) to potlatch2
  • Owner changed from richard@… to potlatch-dev@…

Component should probably be set to 'firefox'...

Will see if I can trace anything though I'm away for a few days so can't promise anything too soon.

comment:3 Changed 6 months ago by Cebderby

Thanks, 3rd user has same - forum thread is at https://forum.openstreetmap.org/viewtopic.php?id=58784
but reports identical problems on a totally different Flash-used website as well. So we may well need a Firefox and/or Flash fix. Using Chrome is ok, so can work round it ok.

comment:4 Changed 6 months ago by Robert Whittaker

Just to confirm I'm seeing this problem too with Firefox 54.0 on Ubuntu Linux, with about:plugins showing "Shockwave Flash 26.0 r0" and https://helpx.adobe.com/flash-player.html reporting version 26.0.0.131.

Potlatch seems to work fine using Chromium on the same Ubuntu system though. According to https://helpx.adobe.com/flash-player.html Chomium is also using Flash 26.0.0.131.

comment:5 Changed 6 months ago by Richard

Tried it with Firefox 54 (OS X), Flash Player 21, and no crashes. Mouse wheel scrolling doesn't work though. Curious.

Edit: fine with Flash Player 26.0.0.131 too. I wonder if this is a Linux-specific issue.

Last edited 6 months ago by Richard (previous) (diff)

comment:6 Changed 6 months ago by Richard

Logged a ticket at Firefox's Bugzilla: https://bugzilla.mozilla.org/show_bug.cgi?id=1374559

comment:7 Changed 3 months ago by Robert Whittaker

  • Summary changed from Potlatch P2 crashes Flash, mousewheel zoom not working, in Firefox 54 to Potlatch P2 crashes Flash, mousewheel zoom not working, in Firefox 54 on Linux

Seems to be a Linux-specific problem, so amending title.

Note: See TracTickets for help on using tickets.