Opened 12 years ago

Closed 12 years ago

#548 closed defect (fixed)

Overflow when selecting a node with 12+ tags

Reported by: jrreid@… Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

If you select a node that has more then 4 tags on it, when you select anything else, or simply deselect it, some of the values stay in place. This arises for GNS imported data, and some TIGER imports as well (see around 49.057244186871834, -111.94035878865704 for example, the placename POI is GNS, the motorway is from tiger)

Change History (2)

comment:1 Changed 12 years ago by richard@…

Status: newassigned

The issue isn't with 12+ tags, it's actually a known bug with any tag containing a colon.

A proper resolution to this requires completely rewriting the tag editing code (planned for a future Potlatch) but there should be a workaround in Potlatch 0.4.

comment:2 in reply to:  1 Changed 12 years ago by richard@…

Resolution: fixed
Status: assignedclosed

Workaround implemented in Potlatch 0.4 (colons in keys are now replaced by | ).

Note: See TracTickets for help on using tickets.