Opened 12 years ago

Closed 11 years ago

#562 closed defect (worksforme)

api/0.5/ways/search returns ways without node refs

Reported by: ted.mielczarek@… Owned by: Tom Hughes
Priority: major Milestone:
Component: api Version:
Keywords: Cc: crschmidt@…

Description

The data returned by the search feature returns ways that don't contain node refs, so the data can't be loaded in JOSM. The nodes are returned in the document, and the ways have their tags, the ways just don't reference the nodes.

Change History (4)

comment:1 Changed 12 years ago by ted.mielczarek@…

Component: adminapi

comment:2 Changed 11 years ago by crschmidt

I can't reproduce on:

http://www.openstreetmap.org/api/0.5/ways/search?type=highway&value=trunk

Can you offer an example URL that this happens for?

comment:3 Changed 11 years ago by crschmidt

Cc: crschmidt@… added

comment:4 Changed 11 years ago by ted.mielczarek@…

Resolution: worksforme
Status: newclosed

I can't seem to reproduce, and apparently I didn't link whatever URL I was trying originally. Resolving WFM.

Note: See TracTickets for help on using tickets.