Opened 12 years ago

Closed 11 years ago

#570 closed enhancement (fixed)

Bezier curves for cycleways

Reported by: fredericbonifas@… Owned by: Knut Arne Bjørndal
Priority: minor Milestone:
Component: osmarender Version:
Keywords: Cc:

Description

As you can see here, only one part of the cycleways are using Bezier curves.

Attachments (1)

ticket570-beziercurves.diff (18.8 KB) - added by Knut Arne Bjørndal 11 years ago.
smart-linecaps.diff

Download all attachments as: .zip

Change History (4)

comment:1 Changed 11 years ago by Knut Arne Bjørndal

Owner: changed from Jochen Topf to Knut Arne Bjørndal
Status: newassigned

Changed 11 years ago by Knut Arne Bjørndal

Attachment: ticket570-beziercurves.diff added

smart-linecaps.diff

comment:2 Changed 11 years ago by Knut Arne Bjørndal

Attached a patch that removes smart-linecap='no' from lots of casings, which is what's causing core and casing to be beziercurved differently.

It has at least one regression: At z12 unsurfaced roads get un-dashed ends for some reason I cannot fathom.

comment:3 Changed 11 years ago by bobkare

Resolution: fixed
Status: assignedclosed

(In [6937]) There were some cases where smart linecaps were disabled for road casings but not cores, which makes them curve differently. Also highway=track + tracktype=grade[3-5] have dashed casings thus needs smart-linecap=no. This is handled a bit sub-optimally at zooms above 14 (or so) because of how the styles were laid out. Closes #570

Note: See TracTickets for help on using tickets.