Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#592 closed defect (fixed)

Potlatch makes duplicated nodes at intersections

Reported by: Skywave Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc: Cameron

Description

Drawing intersections with potlatch seems not to be working at all times. It happens on intersections, instead of making one node with two ways or more connected it just makes a new node on exactly the same place. I don't know if this is a error in the coding or just user stupidity. If it is user stupidity it might be better to make it more clear if a intersction is drawn or not. I gave this priority major because i have found many duplicated nodes all caused by potlatch. Attached is an OSM file which is a good example of this bug. Run the Validator plugin over it in JOSM and you will see that allmost all of the duplicated nodes are connected to a way created by Potlatch.

Change History (9)

comment:1 Changed 12 years ago by Skywave

Sorry for the duplicates, got error said that the attachment was too big. Didn't thought that it was already submitted by then. Because the attachment was too big here is an link to use in JOSM http://www.informationfreeway.org/?lat=51.39074070713436&lon=-0.07507854806209917&zoom=13&layers=B000T000

comment:2 Changed 12 years ago by richard@…

Status: newassigned

I can see the evidence but can't find any way of reproducing it, which puzzles me. Will continue to investigate but would appreciate further reports from anyone who can provide steps to reproduce.

comment:3 Changed 12 years ago by Skywave

I can reproduce it, just made many intersections in my "potlatch test area" in an unused part of France where i mapped. But the thing i can't find is any pattern in this behavior. Sometimes it goes wrong sometimes it goes okay. Things i tried: 1 making an existing way and having the new way end in the middle 2 Making a new way make an old node part of it. But there is no pattern because both sometimes have no failure. What is striking is the high percentage of errors in my little test. I guess 80 percent had duplicated nodes of the 20-30 times i tried.

You can use this little area here: http://www.openstreetmap.org/index.html?mlat=42.51801881482951&mlon=2.319989741464074&zoom=11 I will delete it before Tuesday to avoid getting it in the planet dump.

comment:4 Changed 12 years ago by richard@…

I still can't reproduce it, I'm afraid! Could you provide a click-by-click runthrough of exactly what you're doing? (e.g. how you're making the junction, how you're ending the way, whether you're pressing Shift at any point, etc.) Sorry for the hassle!

comment:5 Changed 12 years ago by Skywave

Question, do have you a recent version of Validator? Looking at the data you created i can find 4 duplicated nodes. Node 132967023 on top of 132967026. Node 132968554/132968542. Node 132968546/132968552 Node 132967619/132967626. It is not a Validator issue either because there are actually two nodes on each other when you shift the upper one.

comment:6 Changed 12 years ago by richard@…

I don't have any version of Validator, I don't use JOSM. :)

Looking at the data there's something weird happening but I can, at last, reproduce it. If you draw an intersection with Potlatch, then click on the nodes, they both have the same id (as they should do). This is why I couldn't see the problem occurring.

However, I now see that if you then reload the edit page, and look at the ids, they're different.

This helps enormously, narrowing it down to a particular piece of code, and I reckon I can solve it from there - will have a concerted effort to fix and report back. Thanks again.

comment:7 Changed 12 years ago by richard@…

Resolution: fixed
Status: assignedclosed

Should be fixed as of r5759 (awaiting deployment at time of writing).

comment:8 Changed 12 years ago by richard@…

Deployed.

comment:9 Changed 12 years ago by Cameron

Cc: Cameron added
Note: See TracTickets for help on using tickets.