Opened 12 years ago

Closed 11 years ago

#611 closed defect (fixed)

Multiple <nd>s with the same ref in a way

Reported by: socks-openstreetmap.org@… Owned by: richard@…
Priority: minor Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

Somehow, the Potlatch user creating the second version of http://www.openstreetmap.org/api/0.5/way/5033272/history managed to create 3 nodes all with the same ref= in them. Fortunately this wasn't hard to sort out, because of the magic roll-back facilities of Potlatch, but it shouldn't have been possible to do in the first place.

Change History (1)

comment:1 Changed 11 years ago by Richard

Resolution: fixed
Status: newclosed

Assuming this was caused by removing interim nodes (e.g. BC from ABCA), Potlatch now traps this.

Note: See TracTickets for help on using tickets.