Opened 12 years ago

Closed 11 years ago

#617 closed defect (fixed)

Plazas not rendering

Reported by: Steve Hosgood Owned by: jburgess777@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

The tagging FAQ seems to indicate that a "plaza" is marked up by drawing a closed way of type "highway=pedestrian" and "area=yes". Osmarender gets this right, Mapnik doesn't. Mapnik seems to ignore the "area=yes" tag and render a closed-loop or pedestrianised road with the name written on that roadway (would be better splashed across the middle of the area).

See http://www.openstreetmap.org/?lat=51.61966&lon=-3.94169&zoom=17&layers=B0F

The centre of the image is Castle Square, Swansea showing as loop of road. Similarly, there's a circular plaza area ("Kingsway Plaza") about 150m to the northwest doing the same thing.

Possibly linked to this is shopping centres not rendering. 150m to the southwest of Castle Square is the Quadrant Shopping Centre. This is rendering as invisible all except for the name which follows part of the periphery-line. Again, Osmarender does this right.

Change History (4)

comment:1 Changed 11 years ago by lh

I can confirm.

This is definitely a major issue.

comment:2 Changed 11 years ago by Tom Hughes

I can confirm you need to get a better sense of proportion. The world is not going to end just because plazas don't currently render on one of the layers.

Personally I hate the area=yes tag and think it is completely wrong headed. I agree that we need a way of tagging plazas etc, I just wish that people had come with something more sensible :-(

comment:3 Changed 11 years ago by Tom Hughes

Owner: changed from Tom Hughes to jburgess777@…

Jon - I guess you to look at this first to make ways with area=yes import into planet_osm_polygon rather than planet_osm_line. Then Steve can look at the stylesheet or something.

comment:4 Changed 11 years ago by steve8@…

Resolution: fixed
Status: newclosed

This was addressed in the revision submitted 03/06/08, and now renders appropriately.

Note: See TracTickets for help on using tickets.