Opened 11 years ago

Closed 11 years ago

#631 closed enhancement (fixed)

Update Mediawiki Extension:ConfirmEdit

Reported by: Grant Slater Owned by: Tom Hughes
Priority: minor Milestone:
Component: website Version:
Keywords: mediawiki Cc:

Description

Kindly update the Mediawiki Extension:ConfirmEdit to a newer revision to support URL Captcha whitelisting.

Discussion here: http://wiki.openstreetmap.org/index.php/Talk:Wiki#ConfirmEdit_Spam_Captcha

Update to at least SVN @ 23122 http://svn.wikimedia.org/svnroot/mediawiki/trunk/extensions/ConfirmEdit/

Change History (6)

comment:1 Changed 11 years ago by Grant Slater

Priority: majorminor

comment:2 Changed 11 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

Done.

comment:3 Changed 11 years ago by osm@…

Resolution: fixed
Status: closedreopened

The update breaks editing logging in.

comment:4 in reply to:  description Changed 11 years ago by osm@…

I think TomH has carried out the extension upgrade, but unfortunately it's broken something. Can't log in to the wiki any more, and I think nobody can edit it. (We're chatting about this on IRC right now actually)

I guess there's a version dependency problem i.e. the latest extension code requires something in the newer versions of MediaWiki?. Some people started listing version dependency problems here: http://www.mediawiki.org/wiki/Extension_talk:ConfirmEdit#undefined_function_wfLoadExtensionMessages

We'll need to roll-back a few versions on the extension (or back to the original version without the upgrade I was requesting) ...or do a MediaWiki? upgrade (might be easier actually)

comment:5 Changed 11 years ago by osm@…

Actually maybe our only problem is we're missing the 'ConfirmEdit_body.php' file because my instructions were wrong. I said copy the two files mentioned on: http://www.mediawiki.org/wiki/Extension:ConfirmEdit#Installation ...but it looks like they've added a third file 'ConfirmEdit_body.php'

comment:6 Changed 11 years ago by Tom Hughes

Resolution: fixed
Status: reopenedclosed

Rolled extension back to rev 27418 which is before it got comprehensively broken by some joker but which still has the white listing stuff.

Note: See TracTickets for help on using tickets.