Opened 11 years ago

Closed 11 years ago

#735 closed defect (fixed)

Autocomplete clicks on keys don't work for freeform values

Reported by: richard Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

achadwick: Okay, from the URL above: highlight the way crossing the dual carriageway, click + and add a string-from-a-list tag like bridge=yes. Blue menus for both, and it "takes".
[11:36] achadwick: Then click + again, choose layer, and (when the bug kicks in), no menu is given for the value, and the grey/light grey tag entry widget is not shown at all. Nothing says "layer" in bold or offers a text entry field.
[11:36] achadwick: It's intermittent. I suggest you try a few times.
[11:36] RichardF: gotcha
[11:37] cjb_ie: dependent on precise location of clicks or some such?
[11:37] RichardF: so it's a bug with clicking on an item from the autocomplete menu
[11:37] RichardF: cjb_ie: very possibly
[11:37] RichardF: ah, no
[11:37] RichardF: it's dependent on whether there is any autocomplete for the value
[11:38] RichardF: so if you have 'highway', for example, that'll work because there's an autocomplete (trunk, primary, motorway etc. etc.)
[11:38] achadwick: That's consistent. It never kicks in with autocompleters like bridge={yes,no}
[11:38] RichardF: but if you have 'layer' or (say) 'ref', it won't, because they're freeform values
[11:38] RichardF: as it happens I'm completely rewriting all the tag editing code at the moment anyway and was working on autocomplete last night... so I'll check it out tonight and see if the bug's still there in my dev version
[11:39] achadwick: Hope that's useful. When you said "gotcha", did you manage to reproduce it yourself?
[11:39] RichardF: yep
[11:39] • Socks hopes RichardF is going to make good on his threat to fork from map_features
[11:39] RichardF: I have to admit I always use the keyboard for the autocomplete so hadn't picked it up

Change History (1)

comment:1 Changed 11 years ago by Richard

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.