Opened 11 years ago

Closed 11 years ago

#787 closed defect (fixed)

Misaligned background

Reported by: Colin Marquardt Owned by: Chris Browet
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

Some operations like changing the size of the drawing area sometimes leave the background layer misaligned versus the map layer.

Looks to me like a redraw is missing sometimes.

Change History (5)

comment:1 Changed 11 years ago by Chris Browet

Owner: changed from bvh-osm@… to Chris Browet
Status: newassigned

I noticed that too, but couldn't reproduce systematically. Do you have a test case?

comment:2 Changed 11 years ago by Colin Marquardt

It's not entirely systematic, but I see it often enough when I (quickly) drag the divider between the map and the properties panel. It seems a bit dragging speed related to me, so it might be a race condition.

I think I have also seen it when I enable the (OSM Mapnik) TMS layer (at high zoom), i.e., from the very start if the tile download, but I cannot reproduce that right now.

comment:3 Changed 11 years ago by Chris Browet

Resolution: fixed
Status: assignedclosed

(In [7203]) FIX : Misaligned background after view resize (fixes #787)

comment:4 Changed 11 years ago by Colin Marquardt

Resolution: fixed
Status: closedreopened

I just had a case where I opened a "fresh" Merkaartor, downloaded an area, (zoomed in rather high,) and downloaded an OSM Mapnik background. The tiles were shifted by what could have been one tile-width to the top and to the left. It seems that it doesn't depend on what tiles you choose as a background, they are all shifted the same way. When I resize the drawing area, the tiles are suddenly aligned (because of the fix you applied above I assume).

comment:5 Changed 11 years ago by Chris Browet

Resolution: fixed
Status: reopenedclosed

(In [7325]) FIX : some more tweaks to background maps. Hopefully fixes #787.

Note: See TracTickets for help on using tickets.