Opened 11 years ago

Closed 11 years ago

#798 closed defect (fixed)

Deleting intersection node in a circular road

Reported by: dantje Owned by: Chris Browet
Priority: minor Milestone:
Component: merkaartor Version:
Keywords: Cc: Chris Browet

Description

Steps to reproduce:

  1. Draw a road that looks like the one in the snapshot attached
  2. Delete the node at the intersection

The loop still remains closed.

If you continue to delete nodes you end up with a road that has a length but only one node.

Attachments (3)

Screenshot.png (46.5 KB) - added by dantje 11 years ago.
Screenshot-1.png (36.7 KB) - added by dantje 11 years ago.
Before removal of point 4
Screenshot-2.png (18.0 KB) - added by dantje 11 years ago.
After removal of point 4

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by dantje

Attachment: Screenshot.png added

comment:1 Changed 11 years ago by Chris Browet

Owner: changed from bvh-osm@… to Chris Browet
Status: newassigned

Could you please indicate in which order you create the nodes and a screenshot after you delete the intersection node.

I cannot reproduce but I probably don't do the right manipulations.

Changed 11 years ago by dantje

Attachment: Screenshot-1.png added

Before removal of point 4

Changed 11 years ago by dantje

Attachment: Screenshot-2.png added

After removal of point 4

comment:2 Changed 11 years ago by dantje

  1. Start merkaator, go to apropriate zoom level
  2. Start road interaction
  3. Create the nodes in the order shown in Screenshot-1.png
  4. Close the loop with the connection of node 9 to node 4
  5. Hit escape to stop the road interaction
  6. Select node 4 and delete it.

The result is shown in Screenshot-2.png. Node 3 and 5 are now directly connected. But node 9 still connects to a ghost node, that cannot be selected anymore.

comment:3 Changed 11 years ago by Chris Browet

Resolution: fixed
Status: assignedclosed

(In [7241]) FIX : if a feature contains a node more than once, if the node is deleted, only the first occurence is removed (fixes #798)

Note: See TracTickets for help on using tickets.