Opened 11 years ago

Closed 11 years ago

#829 closed enhancement (fixed)

Update MediaWiki

Reported by: edoardo@… Owned by: Tom Hughes
Priority: minor Milestone:
Component: website Version:
Keywords: MediaWiki Logs Cc:

Description

Please update the mediawiki installation (now is 1.9.13 while the latest is 1.12.0). The memory overflow 'couse the massive template usage in Map_Features would disappear.

And, please, enable the Special:Log/newusers plug-in!!!

Change History (5)

comment:1 Changed 11 years ago by Tom Hughes

If somebody can give me simple, guaranteed to work and not fk up our configuration instructions then I will do my best.

Note that anything which starts by telling you to back up by following the "simple" mediawiki instructions for backing up is, by definition, not simple.

comment:2 Changed 11 years ago by edoardo@…

If you want i can ask to an italian mediawiki from WikiMediaItalia? to help you about the upgrade.

comment:3 Changed 11 years ago by edoardo@…

TomH wrote: "guaranteed to work"

hey.. WTF.. when did you see a "guaranteed to work" procedure in the IT world? I just know Play & Pray procedures... :)

comment:4 Changed 11 years ago by Tom Hughes

The problem is that PHP applications seem to be entirely based around a very high level of praying... Mostly because they almost always mix up the static program code and data that comes with the application with the configuration information and user generated data so that when you do an upgrade you're never sure that you're accidentally overwriting something important that has been changed.

Given that the upgrade instructions are usually something like "untar this new tarball over your existing installation" any sensible system administrator immediately runs away screaming, especially when they realise that the existing installation includes all sorts of configuration changes made by many people over a long period of time.

comment:5 Changed 11 years ago by Tom Hughes

Priority: criticalminor
Resolution: fixed
Status: newclosed

MediaWiki? has been updated to 1.12.0 as requested.

Note: See TracTickets for help on using tickets.