Opened 11 years ago

Closed 10 years ago

#841 closed defect (fixed)

Upload order seems to be wrong when merging nodes

Reported by: ColinMarquardt Owned by: koying
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

A few times oin the past I had the effect that I got a status 412 from OSM when uploading edits.
When I try a second time, it uploads without a problem. The items left over for the second try are always "Remove trackpoint".

This happens to me when using the new "merge nodes" function (say I have e.g. a road and a separated wood area where I merge their nodes so that the road goes exactly along the edge of the wood).

Change History (8)

comment:1 Changed 11 years ago by koying

  • Owner changed from bvh-osm@… to koying
  • Status changed from new to assigned

comment:2 Changed 11 years ago by koying

Does that happen after loading from a .mdc or systematically?

Because I found a nasty bug regarding the history for merged nodes when reloading.

comment:3 Changed 11 years ago by ColinMarquardt

I'm not loading from a .mdc file. It seems to happen systematically with the procedure above, but I confess I haven't done that test very, uhm, systematically.

comment:4 Changed 11 years ago by koying

I cannot reproduce.

If you could describe a step-by-step testcase, it would help

comment:5 Changed 11 years ago by dantje

I also see this issue. When uploading the "REMOVE"s can not be applied, there is an error message that complains about the precondition. When I upload again, the remaining remove action are applied.

comment:6 Changed 11 years ago by bvh

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7863]) FIX : upload order when merging nodes
-> closes #841
The problem is merging two nodes that are part of two different roads will delete
one of them. But if the update of the road using that node is postponed to later
because another change the server will complain. The fix is to do all deletes
at the end in a seperate stage

comment:7 Changed 11 years ago by ColinMarquardt

  • Resolution fixed deleted
  • Status changed from closed to reopened

I now have a case where this fix doesn't work (so maybe it's something different). I'm trying to delete way 24229285, but as soon as I do that and try to upload, I get an error 412, persistent this time.

This way resulted from a split with way 24422811 (to the southeast), where the node 251062854 that is shared between them is the result of a "Merge nodes" operation.

Maybe Merkaartor is working fine now but the data is strange because of my previous edits with Merkaartor there?

Also, I think way 2442281 is actually two ways using the exact same nodes - can Merkaartor display such cases, or possibly even edit them?

comment:8 Changed 10 years ago by koying

  • Resolution set to fixed
  • Status changed from reopened to closed

Assume fixed in [8379]

Note: See TracTickets for help on using tickets.