Opened 11 years ago

Closed 10 years ago

#845 closed defect (fixed)

Cannot cancel a search once it is started

Reported by: Shaun McDonald Owned by: Tom Hughes
Priority: minor Milestone:
Component: website Version:
Keywords: Cc:

Description

When you start a search, there is no way to cancel it, other than to reload the page.

Change History (6)

comment:1 Changed 11 years ago by Tom Hughes

That's HTTP for you... The best you could do is to pretend to cancel it (by ignoring the result when it comes back) but the server would still be doing the work.

comment:2 Changed 11 years ago by Tom Hughes

Component: adminwebsite
Priority: majorminor

comment:3 Changed 11 years ago by Shaun McDonald

It is more a problem of the UI locking up, rather than anything else.

comment:4 Changed 11 years ago by Tom Hughes

The UI doesn't lock up does it? You probably can't initiate another search because the box will have vanished, but the UI in general should be fine.

The problem is a lack of screen real estate - that is why it reuses the space used by the search box for the search in progress indication but it also means there isn't really much space for a cancel button.

The same goes for an explicit search button which has been asked for several times and which is actually a more important issue to my mind.

comment:5 Changed 11 years ago by Shaun McDonald

Your explaining the problem better than me. I think that adding that extra button will resolve this.

comment:6 Changed 10 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

This is effectively solved by the async search - you can close the search results or start a new search while the previous one is running.

Note: See TracTickets for help on using tickets.