Opened 11 years ago

Closed 8 years ago

#861 closed enhancement (fixed)

Error reverting joined ways

Reported by: Dirk Stoecker Owned by: richard@…
Priority: minor Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

When two ways are joined and the option to revert to an older history is used, the joined way part is lost totally. It is also not reachable by undelete.

Fix: When reverting to old state, the state of the previous seperate way must also be reconstructed.

Change History (2)

comment:1 Changed 11 years ago by richard

Priority: majorminor
Type: defectenhancement

This is a design problem, not a bug or error. OSM does not have any serverside support for joining ways. Editors must perform the operation by deleting one way and adding its nodes to the other.

Consequently there is no way to revert joined ways to two separate ways - this information simply isn't stored.

The solution would be to enhance the undelete functionality and I'll look into this.

comment:2 Changed 8 years ago by Grant Slater

Resolution: fixed
Status: newclosed

Potlatch 2 is now out. Potlatch 2 does not have a live mode, undo and redo work as expected.

Note: See TracTickets for help on using tickets.