Opened 11 years ago

Closed 11 years ago

#868 closed defect (fixed)

segmentation fault when uploading area with a hole

Reported by: sl-openstreetmap@… Owned by: Chris Browet
Priority: critical Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

Using svn revision 7560 merkaartor exits with 'segmentation fault' when trying to upload an area with a hole in it (I'm trying to map a lake with a small island in the middle).

Uploading simple areas works fine as does uploading the lake first and then the hole as separate area (I'm not sure if the end-result is the same as uploading an area with a hole).

Change History (3)

comment:1 Changed 11 years ago by Chris Browet

Owner: changed from bvh-osm@… to Chris Browet
Priority: majorcritical
Status: newassigned

Promoted to "Critical" due to crash

comment:2 Changed 11 years ago by Chris Browet

I cannot reproduce.

Could you please confirm if the bug is still present and, if so, provide a test case.

comment:3 Changed 11 years ago by sl-openstreetmap@…

Resolution: fixed
Status: assignedclosed

I can no longer reproduce this either using current svn. Closing as fixed.

Note: See TracTickets for help on using tickets.