Opened 11 years ago

Closed 11 years ago

#898 closed defect (fixed)

Potlatch ignores keys

Reported by: amai Owned by: Richard
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

Since one of the latest potlatch 0.9 releases (definitly with 0.9a) it often ignores input from keyboard, like Fx, ENTER, etc. Does not happen always but observed it right from the beginning as well as during editing. Environments are: Firefox 2.0.0.14, on Windows XP and Vista.

Could be something else but potlatch, but how comes I see this on two different machines?!

Change History (20)

comment:1 Changed 11 years ago by Astrofreak85

Owner: changed from richard@… to Astrofreak85
Priority: majorblocker
Status: newassigned

I can ack this

ENTER (to end an way), backspace and ESC aren't working anymore! would be great if this could br fixed quickly

comment:2 Changed 11 years ago by amai

@Astrofreak85: are you sure you want the bug to be assigned to you??

comment:3 in reply to:  1 Changed 11 years ago by erik@…

What systems are you running and how do you make this happen?

comment:4 Changed 11 years ago by Richard

Priority: blockermajor

I suspect this may be a Flash Player performance bug related to changing MovieClip?._alpha (used for the new Caps Lock toggle) - am investigating.

comment:5 Changed 11 years ago by Shaun McDonald

I've disabled my caps lock key, as I kept hitting it instead of shift, so any functionality that requires it should be available through some other method too.

comment:6 Changed 11 years ago by Andy Allan

Shaun: That's clearly a separate trac ticket, nothing to do with this.

As for the original problem, I can confirm for

  • ubuntu hardy 8.04
  • Firefox/3.0b5
  • Adobe Flash player 9,0,124,0

It's happened to me a few times.

comment:7 Changed 11 years ago by mobafan

I can confirm it (for at least ESC and DEL keys, see http://www.openstreetmap.org/user/mobafan/diary/1633) with Firefox 2.0.0.14 (Windows 2000, XP, Vista).

comment:8 Changed 11 years ago by Richard

Very odd!

Can anyone confirm whether this is accompanied by a general slowdown, or if the missing keys are the only symptom?

comment:9 Changed 11 years ago by mobafan

Sometimes Richard, potlatch 0.9a was very slow (but not all the time). Yesterday evening it was nearly unusable - it neede more than 30 minutes to load only some roads in Bad Oeynhausen.

comment:10 Changed 11 years ago by Shaun McDonald

The keyboard stops working, but the mouse continues to work. The problem is intermittent.

comment:11 Changed 11 years ago by richard

I've committed a fix based on my best guess as to what could be causing the problem. Would appreciate further reports.

comment:12 Changed 11 years ago by osm@…

With Firefox 2.0.0.14 on Windows XP the DEL Key not work. With the same FF Version on Mac OSX it Work's.

regards.

comment:13 in reply to:  8 ; Changed 11 years ago by pherison

I can confirm too: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Keyboard-shortcuts in the map suddenly doesn't work anymore ([ESC], [Del], [R], [+]). In the key/value-editor they ([+], [R] and [Del] in this example) still work perfect when this happens.

comment:14 in reply to:  13 Changed 11 years ago by pherison

Aditional info: Sometimes it helps switching from "Edit" to "View" and back to "Edit" but not always.

comment:15 Changed 11 years ago by Shaun McDonald

I currently can't use the keyboard suddenly on Mac OS X 10.5.2, Safari 3.1.1.

comment:16 Changed 11 years ago by Richard

Owner: changed from Astrofreak85 to Richard
Status: assignednew

comment:17 Changed 11 years ago by Richard

Would be helpful to know how you're starting Potlatch (exact sequence of clicks) when this occurs.

comment:18 Changed 11 years ago by Richard

This seems to reproduce it:

  1. Have the "splash screen" enabled (i.e. not 'Don't show this again')
  1. Start Potlatch using a GPX track (i.e. click 'edit' from the 'GPS Traces' page, ?gpx=n in the URL)
  1. Start drawing a way before all the ways are fully loaded

comment:19 Changed 11 years ago by Richard

Think I've identified it. Will hopefully fix later today, but until then, opening the options dialogue, then closing it, should recover the keyboard.

comment:20 Changed 11 years ago by Richard

Resolution: fixed
Status: newclosed

Fixed in 0.9b.

Note: See TracTickets for help on using tickets.