Opened 11 years ago

Closed 10 years ago

#899 closed defect (fixed)

Potlatch 9a freezes

Reported by: mike@… Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: memory Cc:

Description

This appears to be related specifically to version 9a - the problem started during a session when upgrade from 9 --> 9a occured.

The cursor freezes or becomes extremely sluggish. After that, multiple versions of this message appear:

"A script in this movie is causing Adobe Flash Player 9 to run slowly. If it continues to run, your computer may become unresponsive. Do you want to abort the script?"

The session is then unusable and has to be aborted.

Environment: IBM Thinkpad laptop R50e, Windows XP SP2 on 1.6Ghz processor with 1GB RAM. Latest Opera and IE browsers (occurs on both).

Can be reproduced with: http://www.openstreetmap.org/edit?gpx=108360

Reproducing the error: I tried restarting the session many times. Sometimes the problem occurs immediately (without starting any edit), sometimes after a minute, once after 30 minutes of editing. The problem also occurs without the GPX track shown above, but takes longer to occur.

It is possible that the problem is related to memory. My PC has 1GB physical memory. Using Task Manager, I notice that "PF Usage" memory creeps up to about 970MB and then the problem occurs. CPU usage then shoots up to 100% and stays there for up to a minute without doing anything. Trying to do anything again causes CPU usage up to 100% again.

Regards, Mike Collinson

Change History (5)

comment:1 Changed 11 years ago by richard

Priority: criticalmajor

Eeeek. I'll investigate, but you're working with a 5Mb GPX track there. I'd be very, very wary of loading a file that size into Potlatch.

Is there any particular interaction you're using (e.g. dragging ways, dragging points, panning map) when the slowdown occurs?

Do you have any background layers turned on?

Do Opera or IE give you any way to show you what files are being loaded (i.e. is Potlatch continually requesting files from the server/Yahoo/whatever)?

comment:2 in reply to:  description Changed 11 years ago by erik@…

Replying to mike@ayeltd.biz:

Can be reproduced with: http://www.openstreetmap.org/edit?gpx=108360

I'll use that the next time I edit Stockholm. That link works for me in Firefox on MacOSX 1GB ram. But I'll test it on my less powerfull Linux laptop.

comment:3 Changed 11 years ago by erik@…

What does happen is that I get a beach ball and lots of CPU usage when loading that page, but after that it works fine. Will try tomorrow, or monday.

comment:4 Changed 11 years ago by Richard

You'll inevitably get a beachball on loading that, it's trying to parse a 5Mb XML file!

comment:5 Changed 10 years ago by Richard

Resolution: fixed
Status: newclosed

No further reports with recent versions so closing.

Note: See TracTickets for help on using tickets.